Why so slow?

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
Bill paid, 1.8 gigs used since midnight  yesterday.  Probably cause my daughter won't stay off youtube. But I should still be able to get a small video to load without buffering. When we first got exede it worked great for the first three months. Now, I can't get many pages to load. Last time I had to call customer service, I was on the phone for over an hour. Most internet pages don't take into account that many of us still have slow speeds. those of us in rural areas are getting left behind. UGH, just frustrated.  
Photo of Tammy

Tammy

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of HMC1940

HMC1940

  • 605 Posts
  • 253 Reply Likes
Maybe there is something updating in background. Also you may have to clean your cache. Every evening before I shut down I do a disk cleanup. I do some YouTube but do them at like 360 or 480 I think it is. No higher. I also do Facebook.Lots of family there and post pictures. I have Liberty 12 and so far have never used up all my gigs. Or maybe you are on a congest beam. I'm on Beam 305 and so far my speeds have been good and no problems. 
Photo of Diana

Diana, Viasat Employee

  • 2215 Posts
  • 417 Reply Likes
Hi Tammy,  I can understand your frustration and we hear you. A new satellite is going to be launched in 2017 to help with some of these issues.  Hang in there.
Photo of Tammy

Tammy

  • 6 Posts
  • 0 Reply Likes
I'm on beam 319. I'll try the disk cleanup. Thanks for the suggestion. Our 2 year contract is up and now we are on a month to month agreement. So we are just waiting to see what happens. Our only other choice for internet is another Sat. provider. Doesn't make sense to switch at this point. I use a lot of mobile pages instead of regular pages and that does help because they use so much less data. Especially the news pages.