SPAM filter doesn't work

  • 1
  • Problem
  • Updated 1 year ago
I suddenly began getting SPAM in my inbox, when I hardly ever got any before. When I originally contacted tech support and complained about it, then ALL my mail began going into my SPAM folder, making it necessary to check my SPAM folder numerous times a day. So I called back again, and now ALL SPAM is coming to my inbox!
In the lower left corner of my mail program, there's a place called Web Apps - Spam filters. I selected the recommended Medium setting, thinking that I could at least get rid of some of the SPAM, but still, every time I open my email, there are a slew of new SPAM messages! Nothing is automatically going to the SPAM folder on its own.
Anybody know a solution?
Photo of Leanne Zinkand

Leanne Zinkand

  • 8 Posts
  • 3 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Old Labs

Old Labs

  • 2996 Posts
  • 2930 Reply Likes
Short of marking/reporting spam and waiting for the machine learning process for spam detection to kick in (it takes multiple reports from multiple users), not much can be done with the Zimbra platform being used by ViaSat.

Once your email address is verified as a valid one, it makes it's way to the spammers and it will only increase exponentially.

Your best option is to sign up for a free Gmail account, the protect and use it for legitimate purposes. It's a pain to then notify all of your legitimate contacts of the new email address but worth it in the long run - even then you're better positioned for the future should you decide to switch ISPs at a later date. GMail, Office, etc. account have much better Spam filtering - primarily because they have a larger subscriber base.

Simply use any ISP provided email address as a throw away for non-critical activities like signing up for newsletters, establishing forum accounts, etc.