Need help troubleshooting slow running internet

  • 1
  • Question
  • Updated 9 months ago
  • Answered
About three weeks ago everything was as fine and running as fast as usual.....ever since then it's been running REALLY SLOWLY! So slow that even if everyone in the family is off of the internet, my daughter can hardly get her online homework done. Even with just her being connected, she has to wait forever for stuff to download. We've unplugged the modem/router several times and nothing helps. It doesn't seem to matter what time of day it is. Even right now at 11:30 am, I'm the only one on the computer and it's running slow. I used to be able to watch Netflix and now it's so slow I've given up. Any help would be much appreciated........thanks!
Photo of s skye

s skye

  • 2 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of Bev

Bev, Champion

  • 3000 Posts
  • 1246 Reply Likes
The first thing to do is connect a single computer directly to the modem using an Ethernet cable and, go to http://testmy.net/ and do 3 sped tests.

That is going to tell us if the router is the problem or not. from there we can troubleshoot other possibilities if it isn't the router.
Photo of Diana

Diana, Viasat Employee

  • 2152 Posts
  • 382 Reply Likes
Hi s skye,   Have you cleared cache, cookies an history on your devices? Here are   articles that will walk through troubleshooting steps for slow speed.
If this does not work, please call ViaSat Customer Care at 855-463-9333 or send an email to exedelistens@viasat.com
Photo of Roy Munson

Roy Munson

  • 24 Posts
  • 7 Reply Likes
I'm not sorry, Exede is slow. This IS the problem. Very tired with (page is unresponsive wait or kill). Exede uses every excuse imaginable your router/wifi etc. Get with the program and repair your mess. Guys this has gotten old.