I was a long time Liberty customer and recently switched our service to an unlimited pckg.

  • 2
  • Problem
  • Updated 8 months ago
  • Acknowledged
I was a long time Liberty customer and recently switched our service to an unlimited pckg. I waited for over a month to receive the new modem/router and have installed it earlier this week.  The modem is installed in my bedroom and the internet only works in my room and approx. 10 feet down the hall.  I never had any problems with my connection with the Liberty modem, as a matter of fact I could receive wifi all over the property which is 5 acres.  My house is only 1700 sq ft, how can I get service throughout the house...HELP!!
Photo of Kelly Lewis

Kelly Lewis

  • 5 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 2
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 3893 Posts
  • 3972 Reply Likes
Many have been complaining about the Viasat Modem/Router's wireless coverage area.

I'll assume you had your own third party wireless router previously. You can continue to use that by connecting its WAN (Internet) to one of the Viasat LAN (ethernet) ports. There are a number of possible configuartions to do this depending on your third party router's brand an model number. Provide us with that info and we can offer some suggestions - often it's simply a matter of connecting the two and simply disabling the wireless capabilities of the Viasat device to regain the covergae you previously had. However, on some occasions you need to confihgure your router to avoid IP addressing conflicts between the two devices.      
(Edited)
Photo of Kelly Lewis

Kelly Lewis

  • 5 Posts
  • 0 Reply Likes
Yes, I was using a Linksys Wireless-G Broadband router Model WRT54GS. 
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 3893 Posts
  • 3972 Reply Likes
OK, are you or someone else familiar with how to configure that router? I took a quick peek and it appears that it may conflict with the default IP Addresses used by the Viasat router.

In a nutshell it appears that that router uses a default IP address of 192.168.1.1 and a DHCP server range of IP addresses starting at 192.168.1.100 - both of those conflict with the defaults used with the Viasat device. If that makes sense go no further and you already know what to do.

However, It would be best to use a wired connection to your Linksys to configure the default IP address and DHCP server ranges to something different before connecting it to the Viasat device.

For example on the following screen capture obtained from setuprouter.com, you'd want to change the items pointed to (Local IP Address and Starting IP Address) to 192.168.0.1 and 192.168.0.100 and save.     



All other options shown (with possible exception of Time Zone) appear to be good also.
 
Reboot the Linksys to determine if you can see its Wireless network. 


If so and at that time you can connect the Linksys to the Viasat device, connect to the Linksys Wireless network and see if you have Internet access.

Just don't make any changes on the Viasat device until verified that the Linksys is working and if that's the case you can then disable the wireless functionality on the Viasat device.

Sounds more complex than it really is... but there are plenty of folks around here that can guide you through it if needed. Just come back and ask...

There are some other config options if it comes to it.

While some claim problems with Linksys routers, apparently you weren't experiencing any and no sense in giving up on it just yet.
(Edited)
Photo of John

John

  • 105 Posts
  • 24 Reply Likes

Hi Kelly - Also, if you connect a router to the Viasat modem, you will want to disable the wifi on the Viasat modem, otherwise you might find that you continue to have wireless connection problems.  Disable it through the Wireless settings and make sure you do both the 5 MHz and 2.4 MHz.

Photo of K Ray

K Ray

  • 1 Post
  • 1 Reply Like
I have the same issue. I will be going back to my TPLink router.
Photo of Kelly Lewis

Kelly Lewis

  • 5 Posts
  • 0 Reply Likes
Ok, tried changing the IP addresses and now I have no internet except on the hard line computer, but can't change the IP addresses back. My laptop can't even find my exede wifi, only the Linksys router, which has no internet...ugh this is so frustrating
Photo of John

John

  • 105 Posts
  • 24 Reply Likes
Hi Kelly - Is the Linksys hard wired to the Viasat modem?  If it is, the Internet setting on it should be set up for "Automatic Configuration-DHCP" as shown in the screenshot from Old Labs.  Then, save settings and then reboot everything (including the Viasat router) and see if you can connect.
Photo of Kelly Lewis

Kelly Lewis

  • 5 Posts
  • 0 Reply Likes
That didn't work john. I'm at a loss, I guess I have unlimited wifi in my bedroom only and no internet throughout the rest off the house. Why is this so difficult
Photo of John

John

  • 105 Posts
  • 24 Reply Likes
Can you post a screenshot of the setup page of your Linksys (similar to Old Labs' above)?
Photo of Kelly Lewis

Kelly Lewis

  • 5 Posts
  • 0 Reply Likes
Photo of Jim16

Jim16

  • 2234 Posts
  • 1937 Reply Likes
Photo of Harvey Mueller

Harvey Mueller

  • 55 Posts
  • 37 Reply Likes
It sounds as if the IP address of the Viasat modem and the Linksys modem are set to the same address.  What address do you use that gets you to the ViaSat modem? 

Plug a hardwire into the Linksys modem and disconnect the cable between the two modems/routers and see if you can access the Linksys configuration at 192.168.1.1.  Then try 192.168.0.1 which is what it should be from above.
Photo of Harvey Mueller

Harvey Mueller

  • 55 Posts
  • 37 Reply Likes
FYI ...

I've seen issues re: range of signal for Exede modem so I disabled the wireless and added my own Linksys EA6350 AC1200+ modem in cascade mode.  Initially I tried adding the modem and it's own config added anything connected to it in the 10.xx.xx.xx realm.  All is well for each device accessing the internet but for example I have a Ethernet connected printer and if it is plugged into the Exede modem, PC's connected to the Linksys router can't print.  I came across the Linksys paper below on cascading routers and now all is well.  I disabled wireless on the Exede modem and turned off DHCP on the Linksys router so now 2 PC's, 1 network printer, NAS storage are now on the same subnetwork and share data and resources regardless of which device they are plugged into as they are all on the 192.168.1.xx subnetwork. 

The directions below refer to a Linksys router but the concept is the same for every router.  Additionally I can access the Exede router at 192.168.1.1 and the Linksys router at 192.168.1.2 from and PC whether connected to The Exede router or the Linksys router. 


Step by step here:  https://www.linksys.com/us/support-article?articleNum=132275
Photo of Harvey Mueller

Harvey Mueller

  • 55 Posts
  • 37 Reply Likes
From the screencap, the IP address 192.168.1.101 was assigned by DHCP in ViaSat/Exede modem.  There is an entry for Linksys setup for default address you specify and not handed one by Exede router DHCP. 
Photo of John

John

  • 105 Posts
  • 24 Reply Likes
Hi Kelly - Try setting the Linksys router's network setup to 192.168.0.1 (see highlight in image), then save settings and restart the router. This hopefully will put it on a different IP network than the Viasat and thus eliminate the conflict.
Photo of Charlie Comstock

Charlie Comstock

  • 15 Posts
  • 11 Reply Likes
I just switched from CenturyLink DSL to ViaSat. The exede modem does not appear to be nearly as effective in reaching throughout my 1,440 sq ft 2 story house as the ZyXel PK 5000Z modem/router that I had been using for years. Can someone tell me if I could hook up this specific model router to my exede router and if so how would I go about it? Thanks!
(Edited)
Photo of Dina Hess

Dina Hess

  • 50 Posts
  • 22 Reply Likes
This is an extremely helpful thread.  Question: I have a Netgear N600 which I would like to use because it had much better coverage area, but it is using the same default IP as the Viasat modem/router.  The Netgear, for some reason, is refusing to let me access its settings -- I can't get past the login.  (It doesn't give me a failed password, it just loops back to the data-entry for the password, which makes no sense to me at all.)  Would it work to change the default IP on the Viasat router instead, since I can log into it without difficulty?
Photo of J&J

J&J

  • 1687 Posts
  • 1003 Reply Likes
 
Dina Hess

It might be easier to work with the Netgear N600.  

I put together a few photos of what to change.  My method will disable DHCP  in the Netgear and leave that work for the Viasat Modem/Router to do. 

My method turns your Netgear N600 into an Ethernet / Wireless Switch.  All wired ports will work on both routers. (yes, lots of wired ports available).  I *think* this also makes it "double-NAT" proof, but not certain. (some devices are really cleaver and just know there are 2 routers out there)

Things that need explaining...

Connect the computer to the Netgear N600 via a numbered port, not the yellow WAN port to make these changes.

After you do Step 3 in my instructions, you will loose contact temporarily with the Netgear N600 because you will be changing the address it is listening on.  The new address will be 192.168.1.2.  Go to this address in your browser to establish contact with the Netgear router in the future. 

The Viasat router will see the Netgear N600 as a static IP device.  If it is possible to enter an IP Reservation in the Viasat router, reliability will increase, but is not mandatory.  That reservation will be 192.168.1.2 and the MAC number of the Netgear N600. 

The Netgear N600 DNS setting is manually set to 192.168.1.1 which is the Viasat Router.  The Viasat Router knows what to do from there.  The Gateway is also set to 192.168.1.1 because that is now your source, the Viasat Router, not the Viasat Modem.  They are two different devices in the same box.

I do strongly suggest disabling the WiFi radio in the Viasat router. I'll explain more later.

To set the Netgear up, it must be connected directly to the computer and configured for it's ultimate use, then connected to the Viasat router.

Boot order: 
#1:  Netgear N600 (it sits there stupid, doesn't know what to do next)
#2:  Viasat Modem/Router (sees a customer and accepts IP address, maps Netgear into it's tables).
#3:  Computer or other devices (Viasat Router sees new clients through the Netgear and issues IP address for them to use).  No need to turn off wireless devices while booting, the Viasat router shouldn't get confused since it's first client is the Netgear N600.  This is why the wireless radio in the Viasat router needs to be turned off.  Another client device could already have 192.168.1.2 in use with the Viasat router...  bummer, since the Netgear is a static device that won't/can't connect on any other address.

More news....  Computers, phones etc...  What address to enter for gateway and DNS if needed?
Everything should use Gateway 192.168.1.1 and the same number for DNS, no matter which router they are connected to (see how simple that was?).

What if all this doesn't work???  Connect Netgear N600 to the Viasat router using a numbered port at the Netgear N600.  Also, do this if a device refuses to work, claiming "double-NAT."

If ANYTHING goes wrong...  (Huh?)  Remember...  I'm not a champion, but Jim16 is !!!  or... The reset button at the back of the router can be a true friend indeed.

Now the pictures, in order:  (click on them for a better view)


 




Photo of J&J

J&J

  • 1687 Posts
  • 1003 Reply Likes
 
I forgot to say....
After all this is done and connected....  You can get to either router from your computer.  Just enter their IP address and things should show up properly.
192.168.1.1 -----  Viasat Router
192.168.1.2 -----   Netgear N600
 
Photo of Dina Hess

Dina Hess

  • 50 Posts
  • 22 Reply Likes
Thanks for this super-detailed reply. I think I have a really good sense of what to do once I can get into the Netgear's router settings -- but as mentioned above, I can't access the Netgear's router settings currently.

The Netgear, for some reason, is refusing to let me access its settings -- I can't get past the login.  (It doesn't give me a failed password, it just loops back to the data-entry for the password, which makes no sense to me at all.)

Further research has shown that this seem to be a known problem Netgears run into. I'm going to try a factory reset on it and go from there.
Photo of Ronald Stricklin

Ronald Stricklin

  • 277 Posts
  • 99 Reply Likes
See if it's in 5ghz mode and if it is switch it to 2.5 ghz mode.
Photo of Dina Hess

Dina Hess

  • 50 Posts
  • 22 Reply Likes
Factory reset worked and the Netgear is now broadcasting throughout the house.  I wish the Viasat router had a better range so none of this extra hassle had been necessary, but at least it's fixed now!  Thanks again for the help getting it set up.
(Edited)
Photo of Ronald Stricklin

Ronald Stricklin

  • 277 Posts
  • 98 Reply Likes
Go into the viasat router settings. And see if it's on 5 ghz band. If it is then it has a lower range and some older devices may not pick up the band. With the distance given it really sounds like that's the problem. If this is the case then switching it to 2.4 ghz band will increase its distance. Go to http://192.168.1.1:8080/ sign in. Go to the wifi settings tab. Click advance settings. And see what band its in.
Photo of Dina Hess

Dina Hess

  • 50 Posts
  • 22 Reply Likes
I've solved the range issue, so that's no longer a problem. The Netgear router gives great range.   But yes, when I was still in that portion of the setup process, switching to 2.4 ghz definitely did help.

It's the speed that's still an issue.  It's slow even with a directly wired connection to the Viasat modem, and speeds with the router are equivalent to when bypassing the router, so I know it's the actual internet coming into the system that's slow and not just a router issue.  Current speed is running 460 kbps.

I will wait for them to reply to the email and go from there.
Photo of Ronald Stricklin

Ronald Stricklin

  • 277 Posts
  • 98 Reply Likes
Check your speed first thing when you wake up. During 3-11pm on a congested beam the speed can get very slow. Further if you are over you data priority limit it will definitely be slower in a portion of this time period. It would be nice if they offered some QoS guarantee, such as 2-5 mbps when the network is congested.
Photo of Dina Hess

Dina Hess

  • 50 Posts
  • 22 Reply Likes
We're not over data priority limit. We only started service 2 days ago. I was sold Viasat 2 but installed on Viasat 1 and am pretty sure that's the root of the speed issues.  It's very frustrating because I wouldn't have signed up for Viasat 1 since I already knew about the over-congestion so commonly reported. I agree that a QoS guarantee would be very reassuring. 
(Edited)
Photo of Ronald Stricklin

Ronald Stricklin

  • 277 Posts
  • 98 Reply Likes
Have them send out a service tech. The no wifi modem was more fault tolerant than the viasat 1's wifi modem. A bent line, a faulty connector, anything like that can have a negative effect. Depending on the variance of speed at 8 am vs 8pm this could be your problem.