Has anyone had problems with Epson WiFi printers since getting Viasat?

  • 1
  • Question
  • Updated 2 weeks ago
  • Acknowledged
I have an Epson XP-600 wireless printer that I used succesfully with DishNet internet for the last three years.  The printer goes into sleep mode on it's own but woudl always wake up when a print job was sent to it.

Two weeks ago we switched to Viasat (currently on Gold plan).  I went to print something today and realized I hadn't changed the wireless settings on the printer.

So here's my problem. I have two networks on my router the vsat5g one and a vsat24g version. My printer will only recognize the 24g one so I entered the password and it connected, but then said something about it might be blocked in the router settings.  I know this isn't the case as I have not logged into the router setup at all.  (I'm not even sure HOW, TBH).

The printer printed fine though so I assumed all was good. Until I went to print again and the computer said the printer could not be found.  Sending a print job won't bring it out of sleep mode now because it's being disconnected while sleeping?  There is no setting in the printer to allow this sleep setting to be turned off. 
When I manually wake it, The printer says it's connected to WiFi but it still won't print.  I have to turn off the printer, cancel the print job from the computer, turn the printer back on and resend the job.  So basically my printer now has to be rebooted every time I want to print something.  Kinda makes the wireless printer useless.  I've tried putting my computer on the same 24g network since Epson mentioned it had to be connected to the same SSID, but that didn't stop it from "Losing" it every time the printer goes into sleep mode.

I never had this problem with DishNet and my Netgear router.. but the Viasat router seems to be dropping the printer or something..
Photo of SamZzz

SamZzz

  • 4 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Joshua

Joshua

  • 210 Posts
  • 65 Reply Likes
I ran into an issue with an HP printer where it could not get a DHCP lease. I ended up adding a DHCP reservation in the router and then setting the same IP address as static in the printer. I also used the external DNS server instead of the router as well.

If you are unfamiliar with making changes in your router settings, I would recommend calling Exede customer care and having them guide you through making the changes on the router.

Hope that helps!
(Edited)
Photo of DigitalArtist

DigitalArtist

  • 12 Posts
  • 15 Reply Likes
I haven't had a problem, but I have my own router and I don't leave the printer on.  I turn it on when I want to use it as I just don't print enough to justify leaving it on.
Photo of Bob

Bob

  • 13 Posts
  • 2 Reply Likes
I had very similar problem for over a year with my HP printer a while back.

After a printer software update along the way, that behavior went away.
Any chance your printer got a software update?

Are there any other devices in your household that can send print jobs?
If so, have you tried printing from them while unable to on your pc? 

(Edited)
Photo of Ronald Stricklin

Ronald Stricklin

  • 216 Posts
  • 76 Reply Likes
Hook up your netgear router to the viasat router and see if there's an issue.