Getting "Invalid Request" errors on some web pages

  • 2
  • Problem
  • Updated 3 years ago
Starting sometime on Labor Day weekend (23rd,24th,25th of May), I started getting a lot of "Invalid Request" errors on certain websites - specifically on  In contact with their website support people, they claim they are seeing bursts of hits to their site, exceeding 7 requests per second from my IP address.  I am just browsing their site using Chromium browser (though it happens with Firefox and an android tablet as well).

I have tried the usual remedies of rebooting modem, router and computer, and disabling all browser extensions.

I am wondering if anyone else is having similar difficulties.  I am further wondering if Exede made any changes at their gateways over the Memorial Day weekend that might result in such errors.  Of course it is possible that DigiKey changed something on their servers, but I am investigating all avenues at the moment.
Photo of Jeremy Lutes

Jeremy Lutes

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Steve Frederick

Steve Frederick, Champion

  • 2468 Posts
  • 1512 Reply Likes
I tried it several times, it loaded quickly every time.
Photo of Exede Lindsey

Exede Lindsey

  • 1827 Posts
  • 163 Reply Likes
Hello Jeremy, that’s strange you’re getting those errors when attempting to access specific websites. I tested the site and gain access with no issues. I’m curious as to why you cannot access. Please feel free to email your account and contact information to .Thank you for posting.