Why is my speed so slow?

  • 3
  • Problem
  • Updated 2 years ago
  • In Progress
  • (Edited)
Not getting the speed I am paying for. cant wait till my contract is up. Worst mistake I have ever made!
Photo of Harold Fink

Harold Fink

  • 1 Post
  • 0 Reply Likes
  • Pisst!!!!!!!!!!!!!!!!!!!!!!!!!!

Posted 2 years ago

  • 3
Photo of Brad

Brad, Viasat Employee

  • 3090 Posts
  • 1089 Reply Likes
Hello Harold,

Could you email us at exedelistens@viasat.com? We can look into if there's any performance issues or if there was a point of sale problem.
Photo of Harold Fink

Harold Fink

  • 1 Post
  • 0 Reply Likes
There is no problem on the this end I have had a certified installer come back to check the equipment.
Photo of Thomas Babers

Thomas Babers

  • 0 Posts
  • 0 Reply Likes
My speed is slow also.....
1.95
Mbps download
2.77
Mbps upload
Latency: 47 ms
Server: Chicago, IL
Your Internet speed is very slow

Internet download speed is very slow. Web browsing should work, but videos could load slowly.
I need and expect faster service I don't really want to change providers but if it can't get faster I will be forced to change.
Photo of Jim16

Jim16

  • 2203 Posts
  • 1909 Reply Likes
Something wrong with your numbers.  Latency for a satellite is 600 ms or more.
Photo of Christy Wineinger

Christy Wineinger

  • 14 Posts
  • 4 Reply Likes
Which is way too high...
Photo of Brad

Brad, Viasat Employee

  • 3090 Posts
  • 1089 Reply Likes
the high latency is within the expectations of the signal going at the speed of light to our satellite and back http://www.exede.com/what-to-expect/
Photo of Christy Wineinger

Christy Wineinger

  • 14 Posts
  • 4 Reply Likes
Which, again, is way too high!!!
Photo of Jim16

Jim16

  • 2203 Posts
  • 1909 Reply Likes
Hey, if you can increase the speed of light, please let all of us know!
Photo of Ronald Couch

Ronald Couch

  • 1 Post
  • 0 Reply Likes
Hah I have been getting a whole .20 mbs download speed. Yes .2ombs!  I have followed the instuctions for restarting the modem and router over 20times today and I did 5 speed tests after each restart.  Ionce got 2mps but only once the average was .20mbs!
Photo of Todd

Todd

  • 1 Post
  • 0 Reply Likes
Same problem.  Just had it installed, last weekend.  Tested out at 16 Mbps with installer here.  Quickly declined from there.  I have rebooted many times.  it will get better for a brief time, then back to 2 Mbps or less.  Sometimes my upload speed beats the download speed.  This is looking like a huge mistake on my part.  I am now stuck for 2 years.  On top of that, it says I've already used 15 GB.  What???  Not really possible.  Could automatic modem updates be stealing speed and using my data???  Not happy at all.  I am considering eating the cancellation charges for the full 2 yr contract.
Photo of Albert Dean

Albert Dean

  • 11 Posts
  • 10 Reply Likes
Same here. In the mornings it's about what it should be. But from the time I get home at around 5:30-6:00 P.M. Central until at least 11 P.M. it's been at barely 1Mbps the past two nights. I've restarted my equipment multiple times. I hope I'm wrong but I think Exede may have jumped the gun and given too many people the Freedom plan before they launched their new satellite.
Photo of Ilona Sadler

Ilona Sadler

  • 3 Posts
  • 1 Reply Like
Photo of Ilona Sadler

Ilona Sadler

  • 3 Posts
  • 1 Reply Like
I can't believe we will be paying over $100 a month for this...