Why am I receiving connection is untrusted message on Firefox?

  • 2
  • Question
  • Updated 4 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

This has been occurring for two days now when I attempt to access my Exede Account Management: dashboard

This Connection is Untrusted

You have asked Firefox to connect securely to my.exede.net, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

my.exede.net uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. (Error code: sec_error_unknown_issuer)

Hope someone can clarify for me. Thanks~
Photo of R Frederick

R Frederick

  • 110 Posts
  • 23 Reply Likes
  • uncertain

Posted 4 years ago

  • 2
Photo of Old Labs

Old Labs

  • 3696 Posts
  • 3712 Reply Likes
It appears that my.exede.net is using a new certificate issued just last week that is not issued by one of those in the Firefox trusted certificate authorities list yet. It does appear to be a valid certificate however. You can wait until Firefox adds it or go through a rather convoluted process when the warning is displayed:

  1. Click I understand the Risks
  2. Click Add Exception
  3. When the dialog is displayed Click View
  4. From Certificate Viewer Select the details tab
  5. Click Export to export the Entrust Certification Authority - L1K certificate and remember where you save it since it needs to be imported later.
  6. Close the certificate viewer
  7. Cancel the Add Security Exception dialog
  8. Select Tools, Options from the Firefox menu
  9. Select Advanced and then the Certificates Tab
  10. Click View Certificates
  11. From Certificate manager, select the Authorities tab
  12. Click Import
  13. Open the Entrust Certificate exported above
  14. Check the Trust this CA to identify websites checkbox
  15. Click OK, Click OK again, and click OK one more time
  16. Refresh the page and it should now be trusted.

 
(Edited)
Photo of Exede Amber

Exede Amber, Employee

  • 135 Posts
  • 23 Reply Likes
Hello R Fredrick, what Old Labs has stated above is very good information to try. In the mean time, I will be looking into this further for you. Once I have further information, I will let you know.
Photo of Warren Smith

Warren Smith

  • 1 Post
  • 0 Reply Likes
I have tried this and get the following error when trying to import the certificate to the authorities tab:
"This is not a certificate authority certificate, so it can't be imported into the certificate authority lists."
Photo of Old Labs

Old Labs

  • 3696 Posts
  • 3712 Reply Likes
Warren,

Exporting and importing certificates in Firefox can be a bit tricky. The following link is to my public OneDrive folder where you'll find a zip file called 'Entrust Certificate Install'. The zip file contains both the certificate in question and instructions for importing the certificate.         

http://1drv.ms/1ECagko

As with anything downloaded from the internet, exercise due caution and read the instructions first since you don't know me from Adam.

Hope it helps.
(Edited)
Photo of Rene Moreno

Rene Moreno

  • 48 Posts
  • 6 Reply Likes

Have an issue with your ISP

File a Formal Complaint with the FCC

http://apps.fcc.gov/ecfs/upload/display

New rules of Net Neutrality!!!!

Photo of Old Labs

Old Labs

  • 3696 Posts
  • 3712 Reply Likes
Have an issue with Firefox - https://support.mozilla.org/en-US/
Photo of Exede Kimberly

Exede Kimberly

  • 879 Posts
  • 202 Reply Likes
Hello Rene, I have reviewed and responded to your comments on Facebook
and look forward to helping you out of your DAP status. Look forward to
hearing from you.

This conversation is no longer open for comments or replies.