Device Management in ViaSat Shield

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)

Logged into the ViaSat Shield app today to have the pop up alerting me my modem does not support device management.
Very frustrated after poor service ever since switching to Viasat and talking with ViaSat reps several times that finally I get acknowledged by corporate and they had a service call for a new modem to be installed to hopefully resolve the poor performance of my internet service, well the new modem helps with not having to hard reboot my modem every couple of hours just to get a semi-stable connection but overall the performance is still poor on just streaming a show in low definition with no other device connected to my network I still can't get a few seconds into a show before having to stop for 2 minutes to buffer to play the next 15 seconds of the show, well tried to see about at least getting a decent deal on a VS-2 connection with no luck..I was hoping I had at least got a new modem that was somewhat up to date and not be lacking device management features!
Photo of Brice Benes

Brice Benes

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 months ago

  • 1
Photo of Matt B

Matt B, Viasat Employee

  • 1095 Posts
  • 521 Reply Likes
For assistance with the Shield app, please email shieldsupport@viasat.com.  Remember, it's in trial, so there's bound to be issues.

For your speed issues, there are several things to try.  Depending on your plan, you may want to change the resolution of the video you're streaming.  If you have one of the Liberty plans, you can turn off the video data extender, just be aware you'll be using more data.  Unlimited plans will stream at different resolutions, depending on the plan level.  Make sure you're streaming at the proper resolution for the plan you're on.  

Also, if you've gone past your priority data, speeds may be affected.  You can view your usage at account.viasat.com.  
Photo of Brice Benes

Brice Benes

  • 5 Posts
  • 0 Reply Likes
I always set the resolution to the lowest option and disconnect any other devices on the wifi as well as closing background services and still no luck I have turned off the video data extender allowed the modem to reboot and still only maybe get to watch a show early in the day other than that no luck, allthough thanks for the response!
Also what extra device management features does the shield app have that the My ViaSat app doesn't?