Viasat browser won't play prime video

  • 1
  • Problem
  • Updated 3 months ago
I am on a dell laptop.  I am trying to watch a Amazon Prime Video and the video says there is a problem with playback.  Tried a couple different videos with same problem.  Don't have a problem on Firefox.  I turned off the ublock for this site but that didn't fix the problem.  I also added Amazon to the list of allowable sites in the flash area in case it was using flash.  Is there something else I should be doing to allow video or is this just a problem?
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like

Posted 3 months ago

  • 1
Photo of Andy Schack

Andy Schack

  • 854 Posts
  • 753 Reply Likes
I'm here at the store and so I'm NOT using Viasat for my internet but am using the Viasat browser and Prime Videos are playing just fine. 


Andy
Photo of GabeU

GabeU, Champion

  • 962 Posts
  • 590 Reply Likes
I wonder if it will work for me.  Going to try it for the heck of it.  A HughesNet customer using a ViaSat browser.  LOL.  
Photo of Andy Schack

Andy Schack

  • 854 Posts
  • 753 Reply Likes
You've really got a sick sense of humor there Gabe LOL

Andy
Photo of GabeU

GabeU, Champion

  • 962 Posts
  • 590 Reply Likes
Oh, now this is just hilarious.  The ViaSat browser is working, and I'm on it as I write this.  ROFLMAO!!!!   

To be honest, though, with it being based on Chrome it's nearly identical to what I already use.  It has a couple of settings which don't apply to me, and I have them turned off because of it, but it's actually working pretty well.  This is just too funny.  I'm going to have to go to the HughesNet board and tell them.  I know a few people on there who would get a kick out of it.  
Photo of Bev

Bev, Champion

  • 3076 Posts
  • 1291 Reply Likes
Did you turn off UBlock to allow the video to load? I can watch Prime Videos just fine in the Viasat Browser but, you do have to turn UBlock off for them to load.
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
Yes, I mentioned that in my post.  That was the first thing I tried.  I opened a new viasat browser window and still won't work.  It shows the ublock turned off but gives me an error still.  
(Edited)
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
I can watch trailers but not the movies or shows where you click a green button to start it.
Photo of Andy Schack

Andy Schack

  • 854 Posts
  • 753 Reply Likes
I'm home now. On VS2. My Wife and kids were watching a show on Netflix and on my laptop I started a movie on Prime....started no problem...let it play for a few minutes just to make sure. 

Andy
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 3893 Posts
  • 3971 Reply Likes
Just a guess and worth a quick shot to see if any impact on Prime videos... but some guesses are wilder than others.

Go into the Viasat Browser Settings - just enter viasat://settings in the address bar. Under Advance Settings, disable "Audio/Video data saver mode" if it's enabled and relaunch - I'm also guessing Viasat wishes it had the relaunch option for Viasat-2 after banging a couple antennas with a hammer ;)


(Edited)
Photo of Tara

Tara

  • 8 Posts
  • 1 Reply Like
That was it! Thanks for your help!
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 3893 Posts
  • 3971 Reply Likes
That setting attempts to save data by forcing a couple HTML5 Video attributes to their less data intensive settings (autoplay off and preload metadata only attributes) - Amazon Prime may actually depend upon the values they set to be unchanged in determining whether the video is playing properly using some dynamic java script.

I use a different browser but have an add-on that does the basically same thing and for some video content providers when it's enabled, videos simply won't play until I disable it. I simply need to toggle it on/off as needed with no need for a "relaunch" - that's the reason it was a guess and even a blind squirrel finds a nut on occasion..     
(Edited)