viasat browser problem

  • 2
  • Problem
  • Updated 2 months ago
  • In Progress
When opening Google search page the cursor is in the wrong place. It is sitting above the box you type in. Clicking in the box does not move it. This is happening in the Viasat Browser only, it works fine in Chrome. 
Photo of James Paramore

James Paramore

  • 186 Posts
  • 61 Reply Likes

Posted 11 months ago

  • 2
Photo of Michael McDowell

Michael McDowell

  • 652 Posts
  • 245 Reply Likes
I have had the same problem!
Photo of Steve Frederick-VS1/Beam314

Steve Frederick-VS1/Beam314, Champion

  • 3181 Posts
  • 2048 Reply Likes
I have the same problem sing the Viasat browser.
Photo of Diana

Diana, Viasat Employee

  • 2409 Posts
  • 474 Reply Likes
Hi James,  Please, If you are continuing to have difficulty, please send us a note at browser@viasat.com.  
Photo of Tom Browser

Tom Browser, Viasat Employee

  • 6 Posts
  • 6 Reply Likes
Official Response
Hi Everyone,

Thank you for calling our attention to this issue. We apologize for any inconvenience this may be causing you.   
We have been able to reproduce it, and are working on a fix that we hope to be available soon. The issue was caused by an unanticipated change to Google’s search webpage.

In the meantime, you can work around it by typing your new search terms into the URL bar (Omnibox) near the top of the window.

Again, we apologize for any inconvenience, and thank you for your patience as we work on the fix.

Thanks,
The Viasat Browser Team
Photo of James Paramore

James Paramore

  • 186 Posts
  • 61 Reply Likes
Thanks. Using the omnibox does not help, the cursor is above the box there also.
Photo of Bev

Bev, Champion

  • 3287 Posts
  • 1463 Reply Likes
Tom means the address bar at the top of the screen, you can type your search terms there and press enter - not on the webpage itself, in the header bar of the browser.
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 4281 Posts
  • 4367 Reply Likes
Use DuckDuckGo as your default search engine - Google is evil ;)

https://duckduckgo.com/

(Edited)
Photo of James Paramore

James Paramore

  • 186 Posts
  • 61 Reply Likes
Same thing in the address bar also. Cursor is above the box.
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 4281 Posts
  • 4367 Reply Likes
They mean to always use the address bar (now referred to as an omnibox by some) for searching - rather than the Google's search box on the page itself - TomBrowser is on the case until a fix can be rolled out.

An omnibox is similar to the traditional web browser address bar, but you can also use it like a search engine - in this case it simply does a search using whatever your default search engine is set as for your browser.

The page rendering issue remains regardless of how you perform the search.  
(Edited)
Photo of James Paramore

James Paramore

  • 186 Posts
  • 61 Reply Likes
I know what they mean, but every box I've tried the cursor is above the box. I'm now using duckduckgo, I like it. 
Photo of Bev

Bev, Champion

  • 3287 Posts
  • 1463 Reply Likes
Hmm, Mine is only off on Google. com, the omnibox is fine, even when it's on Google search pages.
Photo of GabeU

GabeU, Champion

  • 2235 Posts
  • 1365 Reply Likes
I loathe that omnibox thing.  Until I could figure out how to set it right I hated when I would try to enter a site address and it would think I was searching.  Ugh.  
Photo of GabeU

GabeU, Champion

  • 2235 Posts
  • 1365 Reply Likes
I loathe that omnibox thing.  Until I could figure out how to set it right I hated when I would try to enter a site address and it would think I was searching.  Ugh.  
Photo of GabeU

GabeU, Champion

  • 2235 Posts
  • 1365 Reply Likes
Oh, joy.  Double post.  Will it double post this?

Wait.  If it double posts a post about double posts, does that make a quadruple post?  
Photo of Tom Browser

Tom Browser, Viasat Employee

  • 6 Posts
  • 6 Reply Likes
Have you tried rebooting the browser, it might help.
Photo of Bev

Bev, Champion

  • 3287 Posts
  • 1463 Reply Likes
I have cleared it, closed and reopened it and, forced it to check for updates. Here's what I'm seeing. "CURSOR" types where the cursor actually is for me.



Photo of Trent Perez

Trent Perez

  • 1 Post
  • 0 Reply Likes
Hey GabeU the omnibox should only perform a search if the typed in information does not resolve to a valid web address (URL)
Photo of DavidBrowserGuy

DavidBrowserGuy, Browser Expert

  • 132 Posts
  • 83 Reply Likes
Hi everyone,
A browser update has been released that addresses this issue.  To apply the update, please close your browser and re-open it. 

Thanks everyone for bringing this issue to our attention!  We apologize for the inconvenience this may have caused.

Regards,
The Viasat Browser Team


Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 4281 Posts
  • 4367 Reply Likes
Works for me but could have sworn when I visited google.com in the past, it established the cursor position in the search box without my having to establish it using mouse or tab. No big deal for me, I no longer use Google search except in rare cases ;)

P.S. Por favor, a way to control when the updates occur for those of us on data challenged plans.
(Edited)
Photo of DavidBrowserGuy

DavidBrowserGuy, Browser Expert

  • 132 Posts
  • 83 Reply Likes
We typically push updates at 3 am unless they are for critical issues so that they are downloaded during the free zone period.  We have also worked to make the update package as small as possible.
Photo of Old Labs (VS1-329-L12FZ)

Old Labs (VS1-329-L12FZ)

  • 4281 Posts
  • 4367 Reply Likes
Mine dropped at 17:00 yesterday to the tune of 49 MB.
Photo of Bev

Bev, Champion

  • 3287 Posts
  • 1463 Reply Likes
Works fine now - all fixed. :)
Photo of Steve Frederick-VS1/Beam314

Steve Frederick-VS1/Beam314, Champion

  • 3180 Posts
  • 2047 Reply Likes
Works properly for me now.
Photo of Michael McDowell

Michael McDowell

  • 652 Posts
  • 245 Reply Likes
DavidBrowserGuy,  

On a somewhat related note---Is there any way to disable the search function in the OmniBox? Also, the suggestion function?  I would much prefer using the OmniBox for just entering web addresses!
Photo of DavidBrowserGuy

DavidBrowserGuy, Browser Expert

  • 132 Posts
  • 83 Reply Likes
You can disable search suggestions by navigating to Settings and then Advanced Settings and then disabling "Use a prediction service to help complete searches and URLs typed in the address bar."  However, there is no way to fully disable the search function in the URL bar.
Photo of Michael McDowell

Michael McDowell

  • 652 Posts
  • 245 Reply Likes
OK, thanks. But it would be nice to be able to disable the search function too!
Photo of DavidBrowserGuy

DavidBrowserGuy, Browser Expert

  • 132 Posts
  • 83 Reply Likes
So sorry everyone... We fixed the above-mentioned issue many months ago, but forgot to post here to let you guys know.  Hopefully, you saw that it was fixed.