The 4 blue lights on my wildblue reciever do not blink like they use too

  • 2
  • Question
  • Updated 2 years ago
  • Answered
Up until a month ago my reciever lights alternated in the blinking sequence. Now they all blink the same on and off. I am losing internet daily now. Can someone explain what the lights are doing?
Photo of Jim Clark

Jim Clark

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Old Labs

Old Labs

  • 3035 Posts
  • 2980 Reply Likes
All 4 flashing in unison and simultaneously is and indicator of an equipment fault.

Click on the following lin k to view your modems status page:

View all of the pages to see if there are any red check marks or error indications which may provide some insight.

However, these are typically issues that may require a service call and you'll need to contact customer care:
Photo of Steve Frederick

Steve Frederick, Champion

  • 2471 Posts
  • 1513 Reply Likes
Jim, when you see all 4 lights flashing together, you should disconnect the power plug to your modem. Wait about 2 minutes or so, then power the modem back up. This should correct the fault. If you continue to have these problems, do as Old Labs wrote above and contact customer support.

Here is the link to the SurfBeam 2 modem manual.  Page 3 describes the meaning of the various lights to show some status indications.
Photo of Jim Clark

Jim Clark

  • 2 Posts
  • 0 Reply Likes
Thanks for the info guys, I apreciate it.
Photo of Brad

Brad, Viasat Employee

  • 2703 Posts
  • 858 Reply Likes
Hello Jim.,
Are you still having problems? If so it may be worth us looking into. If you haven't done so already please email us at or call us at 855-463-9333 because if there's an issue with the equipment we'll want to get that taken care.
Photo of scott jamerson

scott jamerson

  • 5 Posts
  • 0 Reply Likes
I have the same issue, but the system works fine. I have a red checkmark on the tria page but in tria properties everyything is green.