Unhappy with service

  • 6
  • Question
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
Ive had excede internet for 5 months now, and ive had a technician out twice to fix a non existent problem. I pay for 25mbs download speed, and the FASTEST ive gotten is 10, the average is around 3-4. Its absolutely pathetic, there thieves. And theres no way out of it, every beam is incredibily congested. THATS WHY. They signed more people up then what the beam can handle. Not to say the ping rate is garbage, but that comes with satelite internet. I was told by someone, that there obligated to supply a minimum amount of download speed according to contract. Anyone hear of this? I will be contacting BBB to figure this out. They have stolen well over 6-700$ from me and now ill have to pay more to get out from them. Any tips / advice / information? ALL i ever get from excede is some garbage about congestion. WELL IF YOU CANT SUPPLY IT THEN DONT OFFER IT. Tired of being robbed by this organization.
Photo of Joshua Yingling

Joshua Yingling

  • 2 Posts
  • 1 Reply Like
  • frustrated, angry

Posted 3 years ago

  • 6
Photo of Tim Spake

Tim Spake

  • 482 Posts
  • 267 Reply Likes
I see you got the typical response from the Esede rep. It totally ignores the fact that you have already been in touch as evidenced by having techs come out twice. My speed right now is a screaming 5.9Mbps, that is fast for me a long cry from 25 I pay for
Photo of sandra

sandra

  • 8 Posts
  • 11 Reply Likes
They are very rude and don't care.
Photo of David Lewis

David Lewis

  • 2 Posts
  • 5 Reply Likes
Same issue here - but I called a tech and was told a new satellite was launching this month that would fix the bandwidth issues. Hasn't happened so I was about to call in again, when I thought I'd see what I could google.

Well, the rep didn't lie, exactly - but even though the launch date was supposed to be this month, it wouldn't be in position until fourth quarter, 2017.

What's more, it sounds like the launch date has been pushed back.

On the one hand, I'm glad something is being done. But sure not pleased with how long it will take; nor with the misdirection from the rep.
Photo of Tim Spake

Tim Spake

  • 481 Posts
  • 267 Reply Likes
Thanks for letting us know on the 4th quarter info..
Photo of Brad

Brad, Viasat Employee

  • 3518 Posts
  • 1320 Reply Likes
To clarify, the launch was delayed from April 25th to Jun 1st. The entire country of French Guiana (where we are launching from) shut down due to civic unrest due to labor disputes and that ultimately affected the space agency we're using. A labor agreement with France was reached a week or so ago and everything is now resuming including the launch schedule with Arianespace. There were a few launches ahead of us and due to the delay and time it takes to launch we've been pushed back a bit (spaceflightnow.com has up-to-date schedule). It really doesn't affect our product launch a great deal at all. It will take a few months of testing and beta trials  before we can offer the service by the new satellite.

 In the meantime, we're seeing a few different plans get offered sort of to ramp up to it. We are continuing to address our speeds in our times when the network is at capacity. Unfortunately this does take time but we have seen some of our more outspoken forum members report that they started to see a turn in the tide. We are seeing non-peak periods that the speeds are meeting or excelling the expected speeds. If anyone has concerns feel free to email us at exedelistens@viasat.com to make sure there's not a overall issue that could be causing poor performance
Photo of Mary

Mary

  • 2 Posts
  • 5 Reply Likes
This is the 5th month that exede has claimed I have used my liberty paid program within the first 24 hours of the month.  I have called numerous times and finally had a new router put in.  Change my passwords every month as they claim someone is scalping my service.  I live in the middle of a field in rural Eaton County so that is unlikely.  Sure enough, May 1st rolled around and when I just checked my mail for the first time today, they claim I have used 47% of what I purchased.  This is just bad service that should be shut down!
Photo of Tim Spake

Tim Spake

  • 481 Posts
  • 267 Reply Likes
Have you shut off any auto updates on phones and tablets? It helped my usage a lot..
Photo of Mary

Mary

  • 2 Posts
  • 5 Reply Likes
Everything but my computer was turned off and unplugged just to make sure.  I believe the equipment is faulty and they are reading usage that does not exist. I emailed the link that other people have suggested and I will see what happens next.

This conversation is no longer open for comments or replies.