Spam still getting thru!

  • 1
  • Question
  • Updated 2 years ago
I keep getting job offer spam emails. I will put directly into junk email folder I my iPhone. Exede wasn't too helpful with chat. Anyone else know why I keep getting them and how to stop more from coming?
Photo of Lee Ann Ferguson

Lee Ann Ferguson

  • 26 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 1
Photo of Wes Menzel

Wes Menzel

  • 77 Posts
  • 14 Reply Likes
SPAM on the internet, is an unavoidable fact of life.  (Spam on toast with a couple of fried eggs, is delicious!)
But anyway...
First thing is to NEVER click on the "Unsubscribe" button or send a reply message to unsubscribe.  That just tells the spammer that they've got a live email address.
Second, go into your mail settings, via the WebMail portal and there you should be able to set a rule for a specific domain/subject line/sender/etc. so that the email automatically goes into the spam box and you never see it.
The fine folks at Exede should be able to walk you through that.
Photo of Lee Ann Ferguson

Lee Ann Ferguson

  • 26 Posts
  • 3 Reply Likes
Thank u Wes and let me say LOVE your pic! So sweet! I don't do any of those things. I go thru email as a list via iPhone mail app and select them and send to junk. Exede sadly has been painfully useless. Any time I have issues and send them questions they send me generic emails with link to info I've already researched. I'll try and do the rule as u mentioned. Hopefully that will help
Photo of Wes Menzel

Wes Menzel

  • 77 Posts
  • 14 Reply Likes
Thanks...the handsome devil in the pic is my youngest, Sherman. :)
But yeah, try the rules.  They'll typically get you a lot further than dropping the emails into the junk folder (Does that even still work?)
Good luck, let us know how it goes.
Photo of Lee Ann Ferguson

Lee Ann Ferguson

  • 26 Posts
  • 3 Reply Likes
Lol no junk folder doesn't work! But it's the only option I had. I went On wildblue page via safari on my iPhone and never found a rule option. Ugh
Photo of Wes Menzel

Wes Menzel

  • 77 Posts
  • 14 Reply Likes
On the "mail.wildblue.net" page...

Click on "Preferences"
Click on "Mail"
Then scroll down to "Spam Mail Options"



There are not a lot of options...but you can filter (block) by email address, or block an entire domain.

Or if you scroll up on the same page, you can actually just forward your email to another account that you have, that might have a better spam filter option. (Just a thought) :)
Photo of Lee Ann Ferguson

Lee Ann Ferguson

  • 26 Posts
  • 3 Reply Likes
I'm going to have go on computer because iPhone doesn't have anything like that. Doesn't give option for full desk top version tho.