Satellite Modem will not power on... no lights, no ethernet link.

  • 1
  • Question
  • Updated 1 year ago
  • Answered
My rented ViaSat Surfbeam 2 Model RM4100, modem will not power on. No lights, nothing. My wireless router works fine on the same power outlet.. I tried powering it on several times and even disconnected the coax and ethernet thinking a short may be there. Nothing.

My service is at a seasonal home in an off grid location with NO phone and no cell coverage.

Viasat support says I MUST call support from the location before they will troubleshoot the modem what will not even turn on.

How do I get this resolved from a location without a phone or cell coverage?
Photo of Andrew Potter

Andrew Potter

  • 0 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Bev

Bev, Champion

  • 3076 Posts
  • 1291 Reply Likes
Andrew, I'm not sure how they will handle that but, I am sure that it can be done, likely by having a service call at the location of the non working modem, which is required to replace it anyway. Send an email with your account and contact information and, a link to this thread to exedelistens@viasat.com, they will get you fixed up.
(Edited)
Photo of Diana

Diana, Viasat Employee

  • 2243 Posts
  • 424 Reply Likes
Hi Andrew,  Please send an email, as Bev suggested.  We will diagnose what is going on. We may need to replace the modem. Send the email with your account and contact information to exedelistens@viasat.com.
Photo of Matt B

Matt B, Viasat Employee

  • 844 Posts
  • 433 Reply Likes
Hey Andrew!

I have your email, expect a response shortly!