Problem Solved ????

  • 1
  • Question
  • Updated 2 years ago
  • Answered
FYI..... I was on a regular Exede data plan for years and decided to change to a Liberty Pass plan. For about the first month it worked great. Then they started enforcing the DAP and it wasn't so great after that. I fully understand that. What I don't understand though is that while on the Liberty Pass plan I had other problems too. I was constantly getting "cannot load page, "cannot find server" and other error messages. Today after being frustrated all morning and almost chunkin the whole mess out the back door, I decided to go back to the exede plan with the free period after midnight. Low and behold, all of my problems disappeared and everything is working perfectly and a lot faster. Not one problem since I changed plans a few hours ago. Doesn't make sense to me but it worked. One difference I did notice is that when I went to the myesvt.exede site and looked at stuff I noticed one difference. Under "Performance" the "packet loss" button was always yellow on Liberty Pass and now it's always green on the Exede Plan. As far as I can tell everything else seems the same. Can an Exede employee please explain why it made such a BIG difference when I changed plans ???
Photo of James Baker

James Baker

  • 24 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Diana

Diana, Viasat Employee

  • 2191 Posts
  • 409 Reply Likes
Hi James,  Liberty Pass customers shows yellow when in Liberty Pass status.  That indicates the account is restricted.  If you just signed up and were put on a new plan, you are not restricted and the value will be green. 
Photo of James Baker

James Baker

  • 24 Posts
  • 0 Reply Likes
OK, thanks, that explains the button colors but why did all my other issues go away,  My service is way better now that I got off the Liberty plan? It was very poor service.  I had all kinds of problems on Liberty Pass.
(Edited)