Port forwarding stopped working

  • 1
  • Problem
  • Updated 4 weeks ago
  • In Progress
Hi.  Something seems to have recently changed (by recently I mean past several months) with port forwarding and I can't figure it out.  I have VS2 with the Spock modem.  I had port forwarding for a home security camera system set up and it was working fine.  Then, the one thing I know changed was my WAN IP which I know it does from time to time. No big deal, I could go into the modem setting and find the WAN IP and change it on my camera viewer application.  However, now the app only works if I am on the same network. Also, what is really baffling me is that my WAN IP from the modem is different than what is showing on the internet as my public IP.  This seems to indicate my connection is behind yet another router or upstream NAT which I am wondering if it is blocking my port forwarding.   I can confirm using port checker tools that my ports are closed. Anyone else experience anything like this or have any ideas?
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes

Posted 5 months ago

  • 1
Photo of Bob Lexus

Bob Lexus

  • 346 Posts
  • 123 Reply Likes
Whatever whatsmyip.com says is your IP is, is your IP
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
Agreed.  Hence my confusion since my modem (and support) is telling me something completely different.
Photo of Old Labs

Old Labs

  • 378 Posts
  • 333 Reply Likes
If the router is showing a WAN IP different than that of whatismyip, it's typically an indication that the ISP is using carrier grade NAT. If that case the router's WAN IP is usually 100.xxx.xxx.xxx or 10.xxx.xxx.xxx.or 192.xxx.xxx.xxx (i.e. private IP addresses).

Perhaps a moderator can weigh in, get on the horn and  determine if Viasat is experimenting with CG NAT on Viasat-2.

If so, Google "Port Forwarding and carrier grade NAT" - it's not easy!
(Edited)
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
What you have described is exactly what I'm seeing.
Photo of Old Labs

Old Labs

  • 378 Posts
  • 333 Reply Likes
Only Viasat can tell you whether they're experimenting or transitioning to carrier grade NAT - I'm not seeing it on Viasat-1 (yet).

I assume you're just using the Viasat supplied modem/router combo device and not an additional third party router - if using an additional router behind the Viasat router you'd be looking at a double NAT issue which you can control. But if Viasat is now experimenting or transitioning to CG NAT on their side it means you're sharing the public IP with multiple subscribers as IPV4 addresses are exhausted. It's why Viasat should be also looking to IPV6 support.

It's a matter of where the sharing through NAT is occurring.        
(Edited)
Photo of Diana

Diana, Viasat Employee

  • 2413 Posts
  • 477 Reply Likes
Hi all, Here is a link that explains how the IP addresses work with Viasat https://help.viasat.com/internet/articles/General/What-s-an-IP-address-and-do-I-need-a-static-or-persistent-one  If this does not help, please call Customer Care at 855.463.9333.
Below is an excerpt
"Your private home network is also called a LAN or Local Area Network.  Within your home network, your router will typically allocate private IP addresses that start with 192.168.1.  The private IP address ensures your husband’s emails go to his iPad — not your desktop — and he can’t check out your Amazon shopping basket. "
Photo of Bob Lexus

Bob Lexus

  • 346 Posts
  • 123 Reply Likes
When I look at my modem's interface, it displays 10.200.85.xxx
When I look at router's WAN interface it displays 184.63.22.xxx (same as whatsmyip)

So are you getting a private address in your router's WAN interface?
I have never seen a public address on the modem interface and is always different from the public IP
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
I'm traveling now which is why I was trying to get my cameras running again.  I'll post the IP variations when I get back next week.  Thanks for everyone's replies.
Photo of Old Labs

Old Labs

  • 378 Posts
  • 333 Reply Likes
Same here...

The modem portion doesn't require a public IP address since it's part of the Viasat private network and performs nor router functionality. The router part of the combo device requests it's WAN IP from Viasat's DHCP server.

Attach another router configured as a router to the Viasat router and you'd get a private WAN IP address from the Viasat router - hence the need for bridge mode to overcome double NAT issues. If Viasat is indeed experimenting with carrier grade NAT, you'd wind up with triple NAT in that case. Combo devices always make things more complicated than they need to be ;) 

 
Photo of Oliver

Oliver

  • 325 Posts
  • 104 Reply Likes
FYI Viasat is doing a type of NAT. Your public IP lives on a VM at the gateway NOT at your modem. Everything* is being forwarded.
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
I never did get this working externally.  It still works on my internal network.  My modem shows my internet IP as 100.127.###.###.  What's my IP on google shows 70.41.###.### as my IP. Using the 100.127 address in my camera config works while on my LAN which to me indicates the port forwarding is set up correctly but I'm being blocked before it gets to the port forwarding rule when trying off LAN.  I wouldn't think I need to change anything in the firewall config or add it to the DMZ.  Again, this used to work and the only thing that change was my public IP and then I've never been able to get it working again.  Any other ideas what may be going on?
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
I'm fairly certain this is being blocked on VS2.  I bought a new Netgear router and put the spock modem in bridge mode and get the exact same results.  External port scans indicate the port is block on either the 100.* or 70.* IPs.  So frustrating this was so simple to get working originally.
Photo of Dane Lawrence

Dane Lawrence

  • 3 Posts
  • 0 Reply Likes
I am having the same issue with my cctv system. Port forwarding worked just fine for about a year, then suddenly I can't see any open ports. I have just lived with it since then. Have you tried calling ViaSat tech support for a solution?
Photo of Old Labs

Old Labs

  • 376 Posts
  • 331 Reply Likes
As suggested above if you can get someone technical from Viasat to weigh in, ask if they've switched to or experimenting with carrier grade NAT - if your modem/router's assigned WAN IP address is 100.x.x.x (as noted by Tom Sellards) this would suggest carrier grade NAT is being used on Viasat's end and you're probably SOL - perhaps a moderator could forward that question to someone technical - and by that I don't mean tier 1 customer support - they wouldn't know unless it's in the script. The problem is getting through to the right person who can answer a simple yes or no question ;)

Google "port forwarding with carrier grade NAT"

My suspicion is Viasat is either experimenting or going with carrier grade NAT to relieve IPv4 exhaustion or as a part of IPv6 migration but it hasn't shown up on Viasat-1 yet.
(Edited)
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
I never tried with support.  Based on my past experience, this is way above their pay grade.  I agree with Old Labs that Viasat has implemented some other NAT.  I gave up and ended up buying a camera system on black friday that doesn't require port forwarding for remote connectivity.
Photo of TQ

TQ

  • 51 Posts
  • 16 Reply Likes
I had the same issue on my cameras for about 5 months. I thought it was my ASUS router causing a double NAT, which blocked port forwarding. I have my Viasat2 modem in bridge mode. I tried everything, I finally gave up. I recently upgrade from Gold 30 to gold 50 and as soon as I did that, the double NAT cleared and all port forwarding ports worked again. No issues ever since.
Photo of Dane Lawrence

Dane Lawrence

  • 3 Posts
  • 0 Reply Likes
After talking to two people at ViaSat, they don't seem to know what Carrier Grade NAT is. My IP format also seems to indicate it is not NAT. I still can't see any configured ports that I opened in my router settings. My next step is to do a router reset and try again.
Photo of Tom Sellards

Tom Sellards

  • 12 Posts
  • 2 Reply Likes
I was using the modem as a router and it was working fine. Then when it stopped I tried a router reset which didn’t work. Then I set the modem to bridge mode and set it up in a new router which still didn’t work. I wish you luck.