Over charge for equipment lease

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged

 When I initially signed up for service my installer told me it was $200 for lifetime equipment lease. After being a customer for two years I discovered my $200 was for a two year lease and it was $300 for lifetime lease. I called my installer and he said he was mistaken and misinformed me. I contacted Exede and they said I would have to pay another $300 for lifetime lease. I was able to talked to someone at corporate and they agreed that was not fair and to let me pay $100 along with my original $200 for lifetime lease but they have to charge me $300 and then give me a $200 credit for bookkeeping purposes. I payed the $100 and now have been trying to get the $200 credit since August. Everytime I call in they agree that it has been approved by cooperate and issue a ticket and I am told to wait 5-10 business days. After wait nothing happens. I have done this 4 times now and still no $200 credit. Very poor customer service.

Photo of Ted

Ted

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Exede Lindsey

Exede Lindsey

  • 1827 Posts
  • 163 Reply Likes
Hi Ted, 

I’m sorry for all the run-around you had to experience concerning your equipment lease fees and charges associated. If you’d like, I can review your account and see what could be the hold up for the credit you looking to receiving. Please send me an email at exedelistens@viasat.com with your account and contact info. Thank you
(Edited)