Need help to enable remote access (Google WiFi, Plex server)

  • 1
  • Question
  • Updated 4 weeks ago
  • (Edited)
Hello all,

It's been a while... work has been totally cray-cray, as the cool kids like to say.

I'm having an issue where, after having made the switch to Google WiFi, remote access no longer works. We had been using an Apple Airport Extreme, but the GWiFi system gives us much better coverage and (what's best for the ViaSat system), the GWiFi system gives us control over usage to the device level, along with usage reporting. Not only could Apple's router not do that, none of the mesh systems we researched could do it to the level which GWiFi could. So, we would really like to stick with GWiFi!

We need remote access for work-related purposes, along with Plex Server purposes. Plex support is most important (used constantly, whereas other apps are rarely used).

I've tried following some advice I've seen in other forums (and here) which relate to a common issue with double-nat, applying port forward settings, DMZ settings, UPNP and so forth. I'm not sure if I'm setting things up properly, but I am sure that every configuration change I've made has failed to work - remote access fails.

Is there anyone who has had a similar issue - and how did you resolve it (or did you resolve it)? Help would be appreciated - and of course, I will report results (good or bad) back to the forum.

Thanks!

-- Rique
Photo of Rique

Rique

  • 189 Posts
  • 78 Reply Likes
  • uncertain

Posted 1 month ago

  • 1
Photo of Rique

Rique

  • 189 Posts
  • 78 Reply Likes
I’m just bumping this, in the hopes that it gets seen. Anyone?
Photo of michael3245

michael3245

  • 39 Posts
  • 6 Reply Likes
I use google wifi as well. Plus a Bit-defender cyber security 2 router. I have not attempted any remote access yet on my devices.  Being a IT guy i would think if you have the VS1 modem you could use the viasat router assign it a Static DHCP reservation on the router.  the internal GWIFI should be able to talk to the device outside. I use to do this with my printer one network be secure one non secure. 

With the VPNFilter malware running around I would be careful about remote access 
Photo of Rique

Rique

  • 189 Posts
  • 78 Reply Likes
That’s what I’ve been trying to do, without any luck. Can you explain what reservation you’re suggesting? The VS1 modem control panel sees those devices which I have plugged into a switch (switch attached to the VS1 router), but not the Mac which is my Plex server (its currently plugged into EN port on one of the GWiFi pucks). I can always re-locate the Plex server to the switch, but that hadn’t worked for remote, which is why I moved it to the puck.

Are you suggesting that I assign a static LAN IP to the VS1 router or to the Plex server or... ?

I’m also wondering what config would be required on the GWiFi and where I should enable DMZ and/or port forwarding - on the GWiFi or on the VS1 modem? UPNP is enabled on both the GWiFi and the VS1 router, should it be?

As you can tell, I’m a little lost here. Thanks
Photo of Rique

Rique

  • 189 Posts
  • 78 Reply Likes
TLDR; Setting up bridge mode finally worked to resolve this, but it was necessary to toggle UPNP off and then on again in GWiFi settings - and there were also problems triggered by trying to add a switch into the network. The bottom line is that bridge mode can be configured to work with the VS1 modem and it will resolve double nat problems.

Full details:

UPDATE...  I've been able to get this to work for most (but not all) applications by putting the ViaSat modem into bridge mode. It was not a simple exercise and did not work at all the first time I tried it.

After having found more info online indicating that bridge mode can work with theVS1 modem, I managed to get it working.

Having done that, the GWiFi works now with remote access for Plex (mostly... the Plex skill for Alexa still does not work, yet other remote access Plex apps do work. I've not tested other apps for remote access yet, but when I check the Plex control panel in server settings, it states that remote is working).

So this is a big improvement! I finally have some remote access to the network.
I'm not sure if the issues I had with bridge mode were due to the GWiFi specifically, or if I would have had similar problems with other mesh systems.

Here are some details on problems I ran into with bridge mode on the VS1 modem:

When I first turned bridge mode on, I had no access at all - nothing worked, internet access was completely down. The only thing which worked was to do a hard reset of the VS1 modem, which set everything back to defaults. Because of that, I gave up on using bridge mode, thinking it just wasn't going to play nice with GWiFi and I went down many unhelpful paths, such as port forwarding, DMZ and the like. It was only after having read a support article specific to the VS1 modem, which stated that bridge mode could be made to work that I decided to try again.

I set up bridge mode again (accessing the VS1 control panel via WiFi), and then set up GWiFi again (not working from scratch, just establishing a new set of config settings for each WiFi point). All went well, I checked for double NAT, that had been resolved... but remote access for Plex still was not working.

At that point, I gave up on remote access to Plex ever working and decided to add my switch back into the net, so that I could use EN backhaul for several of my devices. Having done that, internet access went completely down again. I'm not sure why that happened, I'm not enough of a network guru to know what changed, but all internet access, remote or otherwise, again failed - completely - there was nothing which worked.

So once again, I did a full hard reset of the VS1 modem and re-enabled bridge, this time keeping the switch out of the equation - and once again, bridge worked and there was no double NAT concern. I'm still not sure why attaching the switch to one of the GWiFi pucks caused a problem, but that's a research project for another day.

The other concern was with the Plex server. For some reason, remote access to Plex failed to work at first... even after having successfully enabled bridge, ensuring no double nat concern. To resolve that, I toggled UPNP (in the GWiFi control panel) off and then back on, saving the config after each step - and then when it still wasn't working, I restarted the Plex server... and finally, remote to my Plex content worked. Eureka!

My one remaining issue is that the Alexa skill does not work still. Alexa complains that "either remote access is not enabled or your server is taking too long to respond" and then directs me to the Alexa app and Alexa help docs. Any other attempt to access Plex remotely is working.

With the exception of the Alexa skill, using bridge mode to enable remote access to our GWiFi net is a qualified success.

I hope this post can be helpful for anyone who might be experiencing the same frustrations I did.

-- Rique
(Edited)