My Liberty 12 pritty much stops when priority is used up, should I not be getting 1mb?

  • 1
  • Problem
  • Updated 1 year ago
  • Acknowledged
My stats right now says
Rx Power:
-46.9 dBm
Rx SNR:
8.4 dB

Is there something wrong, cause it takes forever to just load PayPal or simple page(s).
PLease help, thanks in advance.
Photo of boB Bachmann

boB Bachmann

  • 3 Posts
  • 1 Reply Like

Posted 1 year ago

  • 1
Photo of vince mattingly

vince mattingly

  • 36 Posts
  • 11 Reply Likes
Have you done a speed test?
Photo of Diana

Diana, Viasat Employee

  • 2190 Posts
  • 409 Reply Likes
Hi boB,  In order to determine what the issue is with your account, please send an email to exedelistens@viasat.com with your account and contact information. If you need immediate assistance, call Customer Care at 855.463.9333 and they can troubleshoot with you. 
Photo of xode0000

xode0000, Champion

  • 475 Posts
  • 151 Reply Likes
Even while on priority data, I speed limit my internet connection to 0.15 Mbps (about 3X dial up) for both upload and download for everyday internet activities, in order to prevent websites from burning up my data.  With that speed limit in effect, I have no problem with any websites, including paypal.  For example, just right now, I went to the paypal website and, with an empty browser cache, it took about 60 seconds to load.  With the browser cache fully populated, it took about 5 to 10 seconds.  This is not what I would call forever.  Further, the loading process was steady with no hiccups or timeouts.  Other websites should have about the same performance.

You should be doing even better since you don't speed limit your connection and, I have never seen Exede be as slow as 0.15 Mbps, even in liberty pass mode.  I wonder if your browser is loading down your internet connection.  Do you by chance use Google Chrome?  Mozilla Firefox is just as bad when first installed but, you can at least turn off its cruft, which you can't with Google Chrome.  Other possibilities are Windows 10 with all of its data burning "apps" that are all turned on by default.
Photo of boB Bachmann

boB Bachmann

  • 3 Posts
  • 1 Reply Like
Does my RX values look OK?
They were taken without any pages loaded.
Also I use SuperAntiSpyware to empty all cookies everyday, always have.
I do use FireFox more than Chrome.
And I don't allow most Windows 10 un-needed apps that update all the time.
Plus I always keep everything logged out so they don't run.
I'm running clean here.
Is that email address to you are just to EXEDE, curious?
How must data am I supposed to have during freedom?
Before I switched to Liberty, I could do all these things when priority ran out.
Thanks for the quick response.
Photo of xode0000

xode0000, Champion

  • 475 Posts
  • 151 Reply Likes
Does my RX values look OK?
Your RX values look fine.  They are almost identical to what mine are right now.
Also I use SuperAntiSpyware to empty all cookies everyday, always have.
That could be a problem right there.  Websites like paypal almost always stop working if the browser cache is populated with their stuff but their cookies have been removed because the stuff that is left in the browser cache is dependent on the cookies that have been removed and when those cookies aren't there, it locks up.  In general, I have found antispyware and other supposed "privacy protection" programs like it that constantly remove stuff from your system to cause more problems than they are worth.
I do use FireFox more than Chrome.
Did you turn off any of its cruft?
And I don't allow most Windows 10 un-needed apps that update all the time.
Plus I always keep everything logged out so they don't run.
Just because those apps are "allowed" or that you are "logged out of them" doesn't mean that they are burning up your data.  Further, Windows 10 itself is a data burner with its ridiculous automatic updates.  Turning off all of data burning stuff in Windows 10 is a major project.  Chances are that you have missed many things.
Is that email address to you are just to EXEDE, curious?
That email address (i.e. exedelistens@viasat.com) goes directly to Exede and not to me.  I am a customer just as you are who simply takes time to answer questions on this forum.
Before I switched to Liberty, I could do all these things when priority ran out.
Did you by chance also switch to Windows 10 at that time as well.  I personally haven't been forced to use that mess yet.
Photo of boB Bachmann

boB Bachmann

  • 3 Posts
  • 1 Reply Like
Thanks for all the tips.
I found the problem.
I did a speed test. Thanks Vince, and it got stuck on the upload test for 9 or 10 minutes and I canceled the test. (TestMy.net)

So I hooked straight to the modem and did a speed test again, and bingo.

So it turned out to be my D-Link(Dl-604)wired router I bought on EBAY.
It listed as new, but had scratches and no packaging or manuals and I just figured it was not like my other wireless routers that setup with an IP address.
So I googled it and checked firmware plus got all the manuals and SETUP address /etc..,and ran its wizard, it seems fine now.

One setting I left as detected (Dynamic IP Address) <hope that's correct for EXEDE?>

You all are so kind and so helpful, I really appreciated the awesome help here very highly, and thanks again for your time and everything you do. 11stars
(Edited)
Photo of Brad

Brad, Viasat Employee

  • 2970 Posts
  • 1034 Reply Likes
Those routers usually turn out to be the culprit in a lot of cases.
Photo of Steve Frederick

Steve Frederick, Champion

  • 2676 Posts
  • 1672 Reply Likes
boB, the Dynamic IP Address is the correct selection.