Liberty Pass Frustration

  • 4
  • Question
  • Updated 3 years ago
  • Answered
I have been happy with liberty pass for my first few months of service. For the last two months the day my liberty pass starts I get a consistent .25 mbps MAXIMUM all day Saturday and Sunday then about 1:30 am the speeds improve. On Friday the .25 speeds start about 4pm until after 1 am. I call the help line and the only answer I get is network congestion. I GET IT!!!!!! In the past network congestion meant .85 mbps for an hour or two, usually well after 5 pm, then I'm running at the speeds I am happy with. April and May its been a frustratingly slow .25 mbps max for a majority of my liberty pass period If I hear network congestion one more time I'm sending your equipment back to you in little pieces.

What the help line representatives fail to explain to me is why my liberty pass speeds for the past couple of months are at such crippling speeds?. Minus the past two months my liberty pass speeds have been reasonable. All I want is for those those speeds be restored. These slows speeds are affecting my health. I'm going to blow a gasket if these slow liberty pass speeds continue.
Photo of masovs127

masovs127

  • 15 Posts
  • 7 Reply Likes

Posted 3 years ago

  • 4
Photo of CHARLES MULKEY

CHARLES MULKEY

  • 3 Posts
  • 2 Reply Likes
Photo of CHARLES MULKEY

CHARLES MULKEY

  • 3 Posts
  • 2 Reply Likes
Finally tonight I have useable speeds. Maybe exede is getting getting the DAP worked out. Btw from 9-11 pm is max peak hours. For the last month and this month from 9-11 pm I usually get around .14-.20 Kbps, but during the day I get around 2-4 Mbps. I will keep an eye on the speeds for non-peak and peak hours.
Photo of Johnny

Johnny

  • 25 Posts
  • 5 Reply Likes
Last night on liberty pass my connection was up and down from 7:45pm to after 11pm most of the time down or useable. This is the speed I am getting during a non peak hour of 6am.
Photo of Moe

Moe

  • 3 Posts
  • 1 Reply Like

I too have been experiencing the issues with dropped packets and inaccessible pages, however since last week, Liberty pass has been restored to where it should be as Exede advertised it should be. I see speeds between 1 mbps and 5 and between the hours of 5pm to midnight it slows down sometimes to 0.7mbps, however it is very usable considering there were no dropped packets or errors to load pages. I am on beam 321 for those who want to know. If you are on this beam, I would like to know if anybody has been experiencing these issues too.

This is a test from today:

I personally believe that Exede has been working on getting their Liberty Pass adjusted to where it should be as they advertised, however somewhere along the lines something broke that started messing up the clients connected or they were testing out to see how everything would run on 256kbps " FYI - it was horrible lol " 

Anyways, I am extremely grateful to have Exede's Liberty Pass available to in my area, if not I would have been stuck with HughesNet. I just wish Exede would alert us about ongoing issues or outages rather than keeping us in dark.

Photo of Brian Shackelford

Brian Shackelford

  • 848 Posts
  • 244 Reply Likes
Can anyone in Beam 329 in Pass mode confirm they are seeing better pass performance at this time or maybe it is just an anomaly that some Pass users in other Beams are seeing better performance? Maybe everyone is out on the lake and vacation so the service just isn't being used as heavily. Crossing fingers as I really want to be on the Liberty Plan again.
Photo of JEP

JEP

  • 987 Posts
  • 718 Reply Likes
I'm still a few days away from hitting my cap and transitioning to Liberty Pass. Though I do have a 6 GB Garmin map update that I need to download....
Will let you know what I see when I get there.
Photo of masovs127

masovs127

  • 15 Posts
  • 7 Reply Likes
I'm on Priority Data now being careful with my data usage on beam 338. Today is the first day of summer vacation for the school kids. I would like to know what to expect once my Priority Data is used up, which will probably be sometime next week. Word from Exede would be nice.
Photo of Joshua

Joshua

  • 214 Posts
  • 66 Reply Likes
Just thought I would chime in, I'm on beam 305 and once we hit Liberty Pass we've gotten a complete disconnection from the internet from about 8:30p - 10:30p with no ping or DNS look-ups going through.

Honestly, I don't mind super slow speeds as long as the connections actually come through and pages load (no matter how slow) but it is more than a little frustrating that I can't event send an email during this time period.

Just my two cents...

Joshua
Photo of Joshua

Joshua

  • 214 Posts
  • 66 Reply Likes
Thought I would say, it being 9:00p right now, that I'm making this post not at home :)
Photo of Joshua

Joshua

  • 214 Posts
  • 66 Reply Likes
One more follow up too, the first time this happened I actually thought my internet connection was out and I gave customer service a call. The support person over the phone mentioned that it was due to congestion but also mentioned something about a known issue with DNS look ups and the Liberty Pass.

So hopefully that will be resolved soon but I think it might be part of the puzzle here.
Photo of Moe

Moe

  • 3 Posts
  • 1 Reply Like

I need to give Exede credit since it is due, at least in my case, the service during the busy times has been restored to how it should be since my last post. Something was not right, but the Liberty Pass is working as it should if not better than I expected, I don't have anymore dropped packets and websites load fine, just slow which I am fine with as long as they load, reminds me of DSL days but I'll take it :) I really don't think Exede is trying to pull anything shady. Something might have been broken or modified improperly but it is getting sorted out. Outside the busy evening hours my internet is pretty good.

On priority data I get about 19mbps down /6mbps up

Speed Test on my computer about 20 minutes ago 1.12 mbps is about 100kb/s

about 4 mbps across my whole home network "including all cellphones and computers"


What I think happened is Exede decided to start implementing its Liberty Pass limitations as it saw congestion on the network and people were complaining that their priority data is not so quick anymore. So they implemented the limitation of 1 to 5mpbs during the busiest times and based on network load, however either it broke along the way or they set it too low to begin with.

Either way it has been getting better and I believe it will be sorted out across all the beams.

(Edited)
Photo of Brian Shackelford

Brian Shackelford

  • 848 Posts
  • 244 Reply Likes
I know they are still working on it, but keep in mind the proposed floor is 256 Kbps so while you may get 1Mbps now that can still go lower. I do believe though that 256 Kbps is too slow for the exede system to handle something or another and they are trying to work that issue out presently. Hoping to hear back from someone at Exede to let us know adjustments have been made.
Photo of Moe

Moe

  • 3 Posts
  • 1 Reply Like

256kbps and high latency is a no go in today's standards, I know it is bad as I experienced it first hand for a good couple of weeks, I can tell you I could not stand it at all. 1mbps is manageable. I really hope Exede sticks to their initial promise and advertisement of the Liberty Plan.

Photo of Brian Shackelford

Brian Shackelford

  • 848 Posts
  • 244 Reply Likes
256 Kbps will work as long as there are no other mitigating factors - even with high latency.  I know Exede is still working on the issue and may have found a resolution.  Go to www.wildblueworld.com/forum if you want to keep up with the latest. 

I expect in the next couple weeks all customers will see the disconnects and browsing issues go away in Pass mode. 
Photo of Josh

Josh

  • 171 Posts
  • 19 Reply Likes
why you keep pushing people to wildblue forums? this is the official forums and this is where they need to be.
Photo of Brian Shackelford

Brian Shackelford

  • 848 Posts
  • 244 Reply Likes
I would suggest going to the forum there and reading through the liberty pass and what's up with exede threads in the troubleshooting section. If you don't want to that is up to you, but more about the issue and progress being made is being discussed there than here. Unsure of why but that is just the case. If do go read them you would understand why I suggested to go. If you don't you will be left with the question you asked and no good answer.
Photo of Bev

Bev, Champion

  • 3287 Posts
  • 1462 Reply Likes
The WildBlue forums are also official forums, they were the only official forums before Exede was introduced.
Photo of Brian Shackelford

Brian Shackelford

  • 848 Posts
  • 244 Reply Likes
Anyone that has been having problems with DAP on Liberty or even classic for that matter that has been seeing page timeout errors or DNS timeouts, please restart your modems this evening and see if performance is better. 

It seems Exede may have gotten to the root of the issue.
Photo of Joshua

Joshua

  • 214 Posts
  • 66 Reply Likes
Thanks Brian,

My billing cycle just reset today, so I'll have to check the next time I hit the Liberty Pass but I'll give my modem a reboot just in case.

Cheers,
Joshua
Photo of masovs127

masovs127

  • 15 Posts
  • 7 Reply Likes
What has been done to resolve the issue? I have 200 mgs until I go on Liberty Pass. I hope I don't have to endure the same problems again.