iMessage strangeness

  • 1
  • Question
  • Updated 3 months ago
Anyone have any issues sending Apple iMessages from an iPhone/iPad using Viasat? For a few weeks now, I fairly often have iMessages that fail to deliver. If I turn off wifi (Viasat) and send via the Verizon cell network, the messages go through. I can use wifi anywhere else (restaurants, church, friends homes, etc), but if I use Viasat at home I get an unusually high incidence of failures to deliver.
Photo of Voyager

Voyager

  • 470 Posts
  • 142 Reply Likes

Posted 3 months ago

  • 1
Photo of TQ

TQ

  • 50 Posts
  • 16 Reply Likes
Try turning on WiFi calling on your iPhone. My wife had same issue and now it works.
Photo of Voyager

Voyager

  • 469 Posts
  • 141 Reply Likes
@TQ, my 5S has no such capability nor do my iPads. They worked fine until a couple of weeks ago. No reason they should not work as they simply use the internet. I suspect Viasat has blocked a port that iMessage uses for some unknown reason. I have not had problems with any other ISP including my former DSL provider.
Photo of Bob Lexus

Bob Lexus

  • 338 Posts
  • 118 Reply Likes
TQ's idea is a good one

Also, how long since you last shut down the phone?
Give it a restart

I have a great deal of experience with wifi calling & use imessage often, trouble free.
Photo of Voyager

Voyager

  • 470 Posts
  • 142 Reply Likes
@Bob, Restarting the phone (even a hard restart) did not address the problem. And iMessage worked fine on Viasat until fairly recently, so I am quite sure they changed something either intentionally or inadvertently, but no way to know for sure as I have also done iOS updates and that could be the problem also. Does iMessage work for you if you turn off wifi calling? It certainly should.
Photo of Bob Lexus

Bob Lexus

  • 338 Posts
  • 118 Reply Likes
I am in no cell service areas often and do often connect to Viasat often via wifi calling also.

But thinking more about it, more voice calls and few iM

Never had a fail to send on Viasat