I can't get to the My Exede dot net site on my Chrome book.

  • 1
  • Problem
  • Updated 4 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

When I click the link that takes me to my exede so I can check my data usage I get re directed to some phony site that comes up with a slash through the https on the top and a warning below showing a red padlock with an X in it. It also has a blue box saying back to security that is clickable but goes no where.
On the phone with Exede they are telling me my Chrome book has a virus. When I try the same exede site from my windows based computer I go right to my sign in page and all works fine.

Any help here? I have been told that Chrome books don't really get hacked and I am not aware of any virus protections for them.
Photo of Gary

Gary

  • 125 Posts
  • 86 Reply Likes

Posted 4 years ago

  • 1
Photo of Old Labs

Old Labs

  • 3702 Posts
  • 3722 Reply Likes
It appears that my.exede.net is using a newly issued certificate that doesn't validate all the way up to a trusted certificate authority.

See https://community.exede.com/exede/topics/why-am-i-receiving-connection-is-untrusted-message-on-firef... for similar symptoms occurring with Firefox and how it's fixed there.

Not familiar with how Chrome handles them but perhaps someone else is and can provide a more detailed explanation on how to fix.

Internet Explorer doesn't appear to have a similar issue with the new certificate.

And don't worry, it's most definitely not a virus... but rather how Firefox, Chrome, Chrome books and perhaps others handle certificate validation. The certificate in question is:

Entrust Certification Authority - L1C

which does in fact verify up to a higher certificate authority.
(Edited)
Photo of HMC1940

HMC1940

  • 605 Posts
  • 253 Reply Likes
This may sound weird--I have Chrome as my browser and the only way I can get into Exede to get to page has  data usage have to use this in address bar mysso.exede.net then of course log in information. If I exede.net sends me to some other page. 
Photo of Exede Amber

Exede Amber, Employee

  • 135 Posts
  • 23 Reply Likes
Hello Gary, Sometimes with Chrome you need to type in myexede.net instead of my.exede.net. I would be happy to look into this for you. Please send me your account information to exedelistens@viasat.com.
Photo of Gary

Gary

  • 125 Posts
  • 86 Reply Likes
Thanks Amber. I spoke with Brian at Exede yesterday and you are already looking in to this for me. Just seems odd that before yesterday I was able to get right to my dashboard using the my.exede.net link but now I can't.

Gary

This conversation is no longer open for comments or replies.