Equipment was returned but Account charged

  • 2
  • Problem
  • Updated 2 months ago
  • In Progress
I disconnected my service on 9/17.  I shipped the equipment back on 10/7/19 and it was received on 10/10/19.  This is based on the UPS Tracking # on the label.  

I received a bill today, 10/17/19,  AND MY BANK ACCOUNT WAS CHARGED $150 on 10/14/19 for Equipment Not Returned!!!  AFTER THE EQUIPMENT WAS RECEIVED!!!

I chatted online with an agent.  He confirmed that my equipment was received.  To sum up the chat, he said he would put in a request for a refund.  And it would take 7-10 days.  He also said should we wait for the refund to process "automatically", it would take 14 days.  He also made comments such as "this is the best we can do", etc. 

In total we chatted for 25 minutes.  Any time there is a problem, it will take a LOT of your time to get it resolved.  And it is ALWAYS not resolved and you will need to continue to follow up.  

This is once again another example of how poor this company is.  People beware - keep track of EVERYTHING.  
Photo of jane

jane

  • 14 Posts
  • 1 Reply Like

Posted 2 months ago

  • 2
Photo of Diana

Diana, Viasat Employee

  • 2409 Posts
  • 474 Reply Likes
Hello JaneFirst, I would like toapologize for the troubles and frustration that you experienced regarding returning your equipment and  refund.  If you need additional assistance, please send an email to viasatlistens@visat.com.  We're here to help.
Photo of jane

jane

  • 14 Posts
  • 1 Reply Like
typo in the email address for viasatlistens 
Photo of margie simms

margie simms

  • 6 Posts
  • 1 Reply Like
Hello Jane apperently this is only for employees to respond to you.  May i say good luck and please don't let them tell you anything that you would not believe otherwise.  I do not want to break the community standers all i can say is reach out to conflict resolution team