Confusion, no service and improper fee

  • 1
  • Question
  • Updated 2 years ago
  • (Edited)
Acct # .........on 6-17-16 I requested an upgrade of my plan which required an upgraded modem. I received, installed and activated the new modem. I also returned the old modem over a week ago. Yesterday 7-7-16 a message was left on my phone that I was being fined $150 for not returning the modem and today 7-8-16 I've no internet service and I received an email to activate my new modem. Something is wrong. I've returned the old modem a week ago well within the 45 days allotted for return and I shouldn't have to reactivate my service and why don't I have service today?
Photo of Judi Van Gorder

Judi Van Gorder

  • 0 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Bev

Bev, Champion

  • 3006 Posts
  • 1249 Reply Likes
This is a public forum for peer support. We cannot see your account here. You will need to email exedelistens@viasat.com, use the live chat form your account management page or, call 855-463-9333 for assistance with this problem.
Photo of Josh

Josh

  • 171 Posts
  • 19 Reply Likes
ALWAYS keep up with receipts and tracking info. be able to show proof you sent it back if the need arises.
Photo of Diana

Diana, Viasat Employee

  • 2152 Posts
  • 382 Reply Likes
Hi Judi,  We received the modem but it takes up to 72 hours to check it in and place the information on your account. You will not be charged for it since it has been returned.  That will happen soon. You will not be charged for it since it has been returned.  

We need to provision the new modem  once it is installed. I see you called in and your service is now working. Is there anything else we can do for you? If so, please send an email to exedelistens@viasat.com.

P.S. I removed your account number as this is a public forum.