Another Mozilla Firefox problem (and how to solve it).

  • 1
  • Idea
  • Updated 1 year ago
  • Not Planned
When upgrading from Firefox 50 or earlier to Firefox 52, you might find that the edges of the text on some websites, and especially the edges of the text inside table cells, are covered up and are not visible.  This makes for a very distracting and irritating read on the website.

Ultimately, after much frustration, the cause of this problem is that the Mozilla Firefox developers, in classic IT arrogance, "ordained" that all Firefox users should use their new "skia" font rendering program instead of the "cairo" font rendering program that was working just fine.  In other words, they so called "fixed" something that wasn't broken and decided to fob their own personal tastes off on all Firefox users.

Fortunately, the fix is quite simple: tell Firefox to use the "cairo" font rendering program instead of the "skia" font rendering program, as shown by the 2 attached screenshots below (click on the image for a full size picture in a new window).  Further details about the problem and its fix are at: https://support.mozilla.org/t5/Firefox/Wrong-font-display-in-FF-52/m-p/1372535





Photo of xode0000

xode0000, Champion

  • 475 Posts
  • 151 Reply Likes

Posted 1 year ago

  • 1
Photo of wm4bama

wm4bama, Champion

  • 331 Posts
  • 220 Reply Likes
I've been using a Firefox add-on called Zoom Page with the option set to automatic....solves a lot of problems...give it a try:

https://addons.mozilla.org/en-US/firefox/addon/zoom-page/
Photo of xode0000

xode0000, Champion

  • 475 Posts
  • 151 Reply Likes
What version of Firefox are you using?
Photo of wm4bama

wm4bama, Champion

  • 331 Posts
  • 220 Reply Likes
I'm using the latest released 32 bit version, 52.0.2
Photo of xode0000

xode0000, Champion

  • 475 Posts
  • 151 Reply Likes
That is also the version that I am now using as well.  However, that version as installed by default has the problem I initially described above until you change the font rendering engine back to "cairo."  I have attached below 2 enlarged examples of the problem I am describing and below that 2 enlarged examples of normal font rendering.  I don't know if your zoom page add-on would solve this problem.  On the other hand, the fix I found did solve this problem.


------------------------------------------------------------------------------------------------------

Photo of wm4bama

wm4bama, Champion

  • 331 Posts
  • 220 Reply Likes
Well, whatever works for you....the Zoom Page add-on is still worth your time to try out...it's simple to install and simple to remove if you don't like it...

It will work no matter what font you use.
(Edited)